Americas (US East) Status

Processing Delays

Incident Report for Turbine Americas US East

Resolved

This incident has been resolved
Posted Aug 21, 2026 - 09:16 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Aug 21, 2026 - 08:41 UTC

Update

We are continuing to investigate this issue.
Posted Aug 21, 2026 - 08:26 UTC

Investigating

We are currently experiencing delays in playbook processing and record actions and are actively investigating the cause.
Posted Aug 21, 2026 - 08:17 UTC
This incident affected: Record APIs and Playbook Execution.