Americas (US East) Status

Processing Delays

Incident Report for Turbine Americas US East

Resolved

The incident has been resolved after a sustained period of normal processing with no further delays observed.
Posted Jan 07, 2026 - 23:34 UTC

Identified

The root cause has been identified, and we are implementing a fix. Only customers using record text searches via the UI are impacted, and may see stale data. We will provide updates as we work toward full resolution.
Posted Jan 07, 2026 - 21:05 UTC

Investigating

We are currently experiencing processing delays and are actively investigating the cause.
Posted Jan 07, 2026 - 20:07 UTC
This incident affected: Platform Status, Orchestration APIs, Record APIs, and Playbook Execution.