Americas (US East) Status

Degraded Full Text Searches

Incident Report for Turbine Americas US East

Resolved

This incident has been resolved.
Posted Apr 01, 2026 - 19:21 UTC

Investigating

We are currently investiagating an incident where full-text searches are returning stale results.
Posted Apr 01, 2026 - 18:43 UTC
This incident affected: Record APIs.