Americas (US East) Status

Degraded full text searches

Incident Report for Turbine Americas US East

Resolved

The incident has been resolved after a sustained period of normal performance with no further issues observed.
Posted Feb 27, 2026 - 16:44 UTC

Monitoring

The fix has been deployed, and we are closely monitoring system performance to ensure stability. The incident will be marked as resolved once recovery is confirmed.
Posted Feb 27, 2026 - 16:16 UTC

Identified

The issue has been identified, and a fix is being implemented
Posted Feb 27, 2026 - 16:06 UTC

Investigating

We are investigating an issue with full-text record searches returning stale results.
Posted Feb 27, 2026 - 15:59 UTC
This incident affected: Record APIs.